OpenRoads Designer CONNECT Edition SDK Help

ProfileElement Methods

Methods

Create1 Construct a profile which pass thru a set of point. The profile is composed with parabolas
Create2 Construct a profile which pass thru a set of point. The profile is composed with half-parabolas
CreateByStartStationEndStationPassThruPoints Construct a profile which pass thru a set of point. The profile is composed with parabolas
CreateFrom3d  
ExtendOrTrimBeginByPointByVerticalProjection(DPoint3d) Extend or trim an element by its start point to the vertical projected point of a given point.
ExtendOrTrimBeginByPointByVerticalProjection(DPoint3d, Double) Extend or trim an element by its start point to the vertical projected point of a given point.
ExtendOrTrimEndByPointByVerticalProjection(DPoint3d) Extend or trim an element by its end point to the vertical projected point of a given point.
ExtendOrTrimEndByPointByVerticalProjection(DPoint3d, Double) Extend or trim a element by its end point to the vertical projected point of a given point.
GetCurvatureAtX(Double) Gets the curvature of the element at a given X
GetCurvatureAtX(Double, Double) Gets the curvature of the element at a given X
GetHighLowPoints(ProfileHighLowPointMode, Boolean) Gets high and low points along the element
GetHighLowPoints(ProfileHighLowPointMode, Boolean, Double) Gets high and low points along the element
GetInReverseDirection Gets deltaX between start and end of the element
GetOffsetProfile(Double) Gets the profile with a given offset from current
GetOffsetProfile(Double, Double) Gets the profile with given offsets from current
GetPointAtX Gets point at given projected distance along a profile element
GetPointsAtEvenProfileElevations  
GetPointsAtY(Double) Gets the collection of points that are at a given Y
GetPointsAtY(Double, Double) Gets the collection of points that are at a given Y
GetShiftedProfileAlongX Shifts a ProfileElement along the X axis.
GetSlopeAtX(Double) Gets the slope of the element at a given X
GetSlopeAtX(Double, Double) Gets the slope of the element at a given X
GetYAtX(Double) Gets Y at a given X location
GetYAtX(Double, Double) Gets Y at a given X location
IsDefinedAtX(Double) Gets whether the element is defined at a given X.
IsDefinedAtX(Double, Double) Gets whether the element is defined at a given X.

See Also